Commerce Server 2009 CTP Announced and available for download

Microsoft Commerce Server 2009 – December 2008 CTP Available for download

 

MS announced Commerce Server 2009 (formerly known as Commerce Server 2007 code name “Mojave”).

Key features includes:

  • out-of-the-box shopping site,
  • SharePoint Commerce Services,
  • and the Multi-Channel Commerce Foundation.

The new out-of-the-box shopping site leverages SharePoint Commerce Services, which provides a gallery of ASP.NET 3.5 Web Parts, a comprehensive e-commerce shopping feature-set, and technology integration between Commerce Server and SharePoint technologies.

 

The Multi-Channel Commerce Foundation provides a new unified, extensible run-time programming model for Commerce Server, including new run-time e-commerce capabilities. The December CTP adds the following capabilities over previous Commerce Server 2007 code name “Mojave” releases:

 

         Update package from Commerce Server 2007, allowing for seamless in-place upgrade of existing deployments.

 

         Complete out-of-the-box e-commerce shopping site in SharePoint with new search functionality, new shopping features, and what-you-see-is-what-you-get (WYSIWYG) content management and design experiences. This helps to facilitate rapid assembly and maintenance of e-commerce Web sites by business users and creative professionals.

System Requirements

  • Supported Operating Systems: Windows Server 2003; Windows Server 2008

Single-server deployments are supported, which consists of running all the Commerce Server 2009 components and software requirements (including Windows and SQL Server) on a single computer. The single-server deployment uses the following software products:  

  • Windows Server 2008, Windows Server 2003 with SP2, or Windows Server 2003 R2 with SP2, and Windows critical updates
  • IIS 6.0 with Microsoft Windows Server 2003 or IIS 7.0 withWindows Server 2008
  • Microsoft Commerce Server 2007 already installed (any version) This is NOT REQUIRED.. It is a Typo on MSDN.
  • SQL Server 2005 SP2 Standard and Enterprise (32-bit or 64-bit) or SQL Server 2008 Standard and Enterprise (32-bit or 64-bit)
  • Microsoft .NET Framework 3.5 with SP1
  • WSS 3.0 (WSS) SP1 or MOSS 2007 SP1

If you are using WSS, , install all the latest updates, QFE and HotFix of WSS3.0. (applicable for your environment)

If you have MOSS installation, install all the latest updates, QFE and HotFix of MOSS. (applicable for your environment)

 

For more information:

http://blogs.msdn.com/rdonovan/

Advertisements
This entry was posted in .NET. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s